Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » Oracle Apex installation error (Oracle , Linux AS4)
Oracle Apex installation error [message #407542] Wed, 10 June 2009 07:43 Go to next message
Messages: 295
Registered: May 2007
Senior Member
Hi All,

I'm trying to test the features of Oracle Apex on 11 g , Rel 1 . I'm done with the Pre-installation tasks, but while Configuring the Embedded PL/SQL Gateway , we need to Run the apxconf.sql Configuration Script and when I run that script , I'm getting the following error when I run the script

SQL> @apxconf.sql

Enter value for httpport: 8081
ERROR at line 5:
ORA-06550: line 5, column 5:
PLS-00201: identifier 'DBMS_XDB.SETHTTPPORT' must be declared
ORA-06550: line 5, column 5:
PL/SQL: Statement ignored

And when checking the below statement also , getting the error .

ERROR at line 1:
ORA-00904: "DBMS_XDB"."GETHTTPPORT": invalid identifier

Can somebody help me on this

Re: Oracle Apex installation error [message #407626 is a reply to message #407542] Wed, 10 June 2009 16:22 Go to previous messageGo to next message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
My wild guess is that the installation of DBMS_XDB wasn't successful. Even connecting as a non-privileged user I think you should be able to see it. Check to see if the pkg is there.
SELECT owner, object_name, object_type, created, TIMESTAMP, status
  FROM dba_objects
 WHERE object_name = 'DBMS_XDB';

Re: Oracle Apex installation error [message #418068 is a reply to message #407626] Wed, 12 August 2009 19:14 Go to previous message
Messages: 1
Registered: August 2009
Junior Member
Hi All,

I had the saaaammmme problem and about 15,000 others. Granted I installed on 10g with the PL/SQL gateway using the built in http server with XML DB which is not officially supported by Oracle, but it was a pain. It is now working beautifully, and here is what I did:

Hopefully this will help with the annoying pop-up authentication windows, images not displaying, yadda yadda.

Craig Glendenning
Previous Topic: Calling APEX page in cognos report
Next Topic: Problem insert data into new table at the same time delete data from existing table
Goto Forum:

Current Time: Mon Dec 06 00:15:53 CST 2021