Home » Server Options » RAC & Failsafe » 11.2 grid upgrade (11.2, rhel5)
11.2 grid upgrade [message #492487] Mon, 31 January 2011 08:26 Go to next message
asangapradeep
Messages: 128
Registered: October 2005
Location: UK
Senior Member
Hi,

I'm testing the grid infrastructure upgrade from 11.2.0.1 to 11.2.0.2 and I need something clarified and your help in this matter is appreciated.

I read through [[http://download.oracle.com/docs/cd/E11882 01/install.112/e17212/procstop.htm#BABEIBEE|Restrictions for Clusterware and Oracle ASM Upgrades]] which states
Quote:
To upgrade existing 11.2.0.1 Oracle Grid Infrastructure installations to Oracle Grid Infrastructure 11.2.0.2 using a rolling upgrade, you must first do one of the following, depending on your platform:

* Patch the release 11.2.0.1 Oracle Grid Infrastructure home with the 9413827 patch, and install Oracle Grid Infrastructure Patchset Update 1 (GI PSU1). When you apply patch 9413827, it shows up in the inventory as GIPSU2 bug 9655006.

* Install Oracle Grid Infrastructure Patchset Update 2 (GI PSU2), which includes the 9413827 patch.


I've also found following Metalink notes with regard to upgrade

Bug 10036834 - Linux Platforms: Patches not found upgrading Grid Infrastructure from 11.2.0.1 to 11.2.0.2 [ID 10036834.8]

Bug 9413827 CRS rolling upgrade from 11.2.0.1 to 11.2.0.2 fails with OCR on ASM

I've had already applied the 9655006 and so I applied the 9413827 which rolled back 9655006 patch. Quote:
Invoking utility "napply"
Checking conflict among patches...
Checking if Oracle Home has components required by patches...
Checking conflicts against Oracle Home...

Conflicts/Supersets for each patch are:

Patch : 9413827

Bug Superset of 9655006
Super set bugs are:
9655006, 9778840, 9343627, 9783609, 9262748, 9262722

Patches [ 9655006 ] will be rolled back.


So I don't know how the recommendation on 10036834.8 could be met.

Anyway I proceeded with the grid upgrade and when I ran the root upgrade I got the following output.


Quote:
Finished running generic part of root script.
Now product-specific root actions will be performed.
Using configuration parameter file: /app/oracle/11.2.0/grid/crs/install/crsconfig_params
Creating trace directory
Failed to add (property/value) : ('OLD_OCR_ID/'-1') for checkpoint:ROOTCRS_OLDHOMEINFO.Error code is 256

ASM upgrade has started on first node.

CRS-2791: Starting shutdown of Oracle High Availability Services-managed resources on 'hpc3'
CRS-2673: Attempting to stop 'ora.crsd' on 'hpc3'
CRS-2790: Starting shutdown of Cluster Ready Services-managed resources on 'hpc3'
CRS-2673: Attempting to stop 'ora.LISTENER_SCAN1.lsnr' on 'hpc3'
CRS-2673: Attempting to stop 'ora.CLUSTERDG.dg' on 'hpc3'
CRS-2673: Attempting to stop 'ora.clusdb.db' on 'hpc3'
CRS-2673: Attempting to stop 'ora.registry.acfs' on 'hpc3'
CRS-2673: Attempting to stop 'ora.LISTENER.lsnr' on 'hpc3'


Though this is not same error message shown on the 10036834.8

Quote:
Failed to add (property/value) : ('OLD_OCR_ID/'-1') for checkpoint:ROOTCRS_OLDHOMEINFO.Error code is 256

The fixes for bug 9413827 are not present in the 11.2.0.1 crs home
Apply the patches for these bugs in the 11.2.0.1 crs home and then run
rootupgrade.sh /oragi/perl/bin/perl -I/oragi/perl/lib -I/oragi/crs/install /oragi/crs/install/rootcrs.pl execution failed
The first line is the same and patch 9413827 is applied.


Then I found the following metalink note

Pre-requsite for 11.2.0.1 to 11.2.0.2 ASM Rolling Upgrade [ID 1274629.1]

which said Quote:
If $GI_HOME is on version 11.2.0.1.0 (i.e. no GI PSU applied).

Action: You can apply Patch:9413827 for version 11.2.0.1.0. This patch includes fixes for both 9413827 and 9706490.
So I created a new installation from the base release 11.2.0.1 and applied the 9413827 patch only and ran the upgrade. But still found that one error line.
Quote:
Entries will be added to the /etc/oratab file as needed by
Database Configuration Assistant when a database is created
Finished running generic part of root script.
Now product-specific root actions will be performed.
yUsing configuration parameter file: /opt/app/11.2.0/grid1/crs/install/crsconfig_params
Creating trace directory
Failed to add (property/value) : ('OLD_OCR_ID/'-1') for checkpoint:ROOTCRS_OLDHOMEINFO.Error code is 256

ASM upgrade has started on first node.

CRS-2791: Starting shutdown of Oracle High Availability Services-managed resources on 'hpc3'
CRS-2673: Attempting to stop 'ora.crsd' on 'hpc3'
CRS-2790: Starting shutdown of Cluster Ready Services-managed resources on 'hpc3'
CRS-2673: Attempting to stop 'ora.CLUSTERDG.dg' on 'hpc3'
CRS-2673: Attempting to stop 'ora.registry.acfs' on 'hpc3'
CRS-2673: Attempting to stop 'ora.DATA.dg' on 'hpc3'
But on both cases upgrade proceeded and grid infrastructure software was upgrade to 11.2.0.2.

I'm confused as to whether the above error line Failed to add (property/value) : ('OLD_OCR_ID/'-1') for checkpoint:ROOTCRS_OLDHOMEINFO.Error code is 256

is expected behavior during upgrade or is there something I can do to fix it.

Thank you.

[Updated on: Mon, 31 January 2011 08:28]

Report message to a moderator

Re: 11.2 grid upgrade [message #498297 is a reply to message #492487] Wed, 09 March 2011 09:07 Go to previous messageGo to next message
asangapradeep
Messages: 128
Registered: October 2005
Location: UK
Senior Member
Hi,

Message from Oracle (after an SR) this is due to Bug 10056593: FAIL TO ADD OLD_OCR_ID PROPERTY FOR ROOTCRS_OLDHOMEINFO. As per this bug the message can be ignored. You can continue with the installation.

hope this helps anyone interested.

Re: 11.2 grid upgrade [message #498315 is a reply to message #498297] Wed, 09 March 2011 10:26 Go to previous message
Michel Cadot
Messages: 67888
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Thanks for the feedback.

Regards
Michel
Previous Topic: Easy Steps to Installation RAC10g
Next Topic: root.sh failed on second node
Goto Forum:
  


Current Time: Wed Jun 23 12:42:25 CDT 2021