Home » Server Options » RAC & Failsafe » TAF server side setup (11.2.0.1)
TAF server side setup [message #501081] Fri, 25 March 2011 12:00 Go to next message
lhollis
Messages: 6
Registered: April 2007
Junior Member
Want to set up server side TAF. Not a whhole lot of documentation out thre that is very specific. created a service and added TAf entries to it.

bttu11:11.2.0/dbhome_1:
/home/oracle> srvctl modify service -d CDRTST -s POSTST -m basic -e select

checking the service shows:

bttu11:11.2.0/dbhome_1:
/home/oracle> srvctl config service -d CDRTST -s POSTST
Service name: POSTST
Service is enabled
Server pool: CDRTST_POSTST
Cardinality: 2
Disconnect: false
Service role: PRIMARY
Management policy: AUTOMATIC
DTP transaction: false
AQ HA notifications: false
Failover type: SELECT
Failover method: BASIC
TAF failover retries: 0
TAF failover delay: 0
Connection Load Balancing Goal: LONG
Runtime Load Balancing Goal: NONE
TAF policy specification: NONE
Preferred instances: CDRTST1,CDRTST2
Available instances:
bttu11:11.2.0/dbhome_1:
/home/oracle>


Yet when I test the failover, I get:

SQL> select * from v$instance;
select * from v$instance
*
ERROR at line 1:
ORA-03113: end-of-file on communication channel
Process ID: 27737
Session ID: 4 Serial number: 19


SQL> select * from v$instance;
ERROR:
ORA-03114: not connected to ORACLE


SQL>


Client side setup works perfectly....but just CANNOT seem to get server side setup and working....

Any suggestions?

TIA
Re: TAF server side setup [message #501111 is a reply to message #501081] Fri, 25 March 2011 17:15 Go to previous messageGo to next message
John Watson
Messages: 8561
Registered: January 2010
Location: Global Village
Senior Member
What is the connect string you are using?
Re: TAF server side setup [message #501393 is a reply to message #501111] Mon, 28 March 2011 14:40 Go to previous message
lhollis
Messages: 6
Registered: April 2007
Junior Member
sqlplus system/password@MYTEST.BTRUCK.COM

LDAP resolves that to scan_listener, and service_name for the service.
Can;t get copy/paste to work here and do not wish to type the whole string....

connection to service works fine, and I am able to get the failover to work 1 time but subsequent connections will fail when instance is shut down under it instead of failing over to surviving instance.

[Updated on: Mon, 28 March 2011 14:41]

Report message to a moderator

Previous Topic: Thread: Oracle 11g R2 Grid Infrastructure Installation stuck on 65%
Next Topic: each RAC EM display started, but can not access via IE
Goto Forum:
  


Current Time: Wed Jun 23 13:52:48 CDT 2021