Home » RDBMS Server » Server Utilities » ORA-00922 during schema export (Oracle Database 11g Enterprise Edition 11.2.0.1.0 64bit Production Windows)
ORA-00922 during schema export [message #683427] Wed, 13 January 2021 03:33 Go to next message
LiorI
Messages: 9
Registered: December 2019
Junior Member
Hello,
Export: Release 11.2.0.3.0 - Production
Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production

Error message in export log:
ORA-31693: Table data object "HEV001"."YOMANLN" failed to load/unload and is being skipped due to error:
ORA-00922: missing or invalid option

Export command that was run on the server computer:
EXPDP.EXE HEV001/MyPassword@INTORCL DIRECTORY=exp_dir1 DUMPFILE=HEV001.dmp LOGFILE=HEV001.log EXCLUDE=GRANT FULL=N REUSE_DUMPFILES=Y FLASHBACK_TIME=SYSTIMESTAMP COMPRESSION=ALL

I copied the table content to a new table with the same structure. Renamed the old table to another name and the new table to the original name.
Now the old table is exported without errors and the new table gets the same error. It looks like that error is tied to the table by its name.
If I export without the FLASHBACK_TIME=SYSTIMESTAMP there is no error, but I don't know if the table export is valid.
"SELECT COUNT(*)" and "SELECT *" queries don't raise an error. "Analyze table validate structure cascade" on that table is ok.

Is the table corrupted? Can I fix the problem or ignore it?
Thanks in advance
Re: ORA-00922 during schema export [message #683429 is a reply to message #683427] Wed, 13 January 2021 04:20 Go to previous messageGo to next message
Michel Cadot
Messages: 68006
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Is this a different than the one you had one year ago.
Too bad you didn't feedback to your topics maybe we could help from the previous errors.

Re: ORA-00922 during schema export [message #683430 is a reply to message #683429] Wed, 13 January 2021 05:01 Go to previous messageGo to next message
LiorI
Messages: 9
Registered: December 2019
Junior Member
It's a different table. This error happens every couple of months to a different customer.
Most of the cases it happened to a table that was inserted or updated by a trigger after an invoice table record was changed.
First time with this table. It has no trigger. Strange there was no error once I changed the table name. Maybe the problem is related to pending changes for this table?
Re: ORA-00922 during schema export [message #683453 is a reply to message #683427] Sun, 17 January 2021 14:41 Go to previous message
LiorI
Messages: 9
Registered: December 2019
Junior Member
Using the original export/import worked without errors.
Trying DataPump export again gave the same error.
Previous Topic: impdp with DATA_ONLY=y doesn't work
Next Topic: Load XML data through sqlldr
Goto Forum:
  


Current Time: Mon Oct 25 11:13:59 CDT 2021