Home » Infrastructure » Linux » install oracle 9.2.0.1.0 on RedHat 9.0
install oracle 9.2.0.1.0 on RedHat 9.0 [message #98866] Mon, 26 May 2003 03:59 Go to next message
marco
Messages: 46
Registered: March 2001
Member
I'm trying to install oracle 9.2.0.1.0 database on RedHat 9.0. Very soon it seems the installation hangs.

When installing Java Runtime Environment its says:

Link pending...

Copying README

0%

At the end of the logfile we find the following:

, [[lib/font.properties.ISO8859_15_FDIS ->%PROD_HOME%/lib/font.properties.ISO8859_15_FDIS 6977 plats=0=>[[46]] langs=0=>[[en]]]]
, [[lib/psfont.properties.ja ->%PROD_HOME%/lib/psfont.properties.ja 2693 plats=0=>[[46]] langs=0=>[[en]]]]
, [[COPYRIGHT ->%PROD_HOME%/COPYRIGHT 921 plats=0=>[[46]] langs=0=>[[en]]]]
, [[LICENSE ->%PROD_HOME%/LICENSE 7548 plats=0=>[[46]] langs=0=>[[en]]]]
, [[README ->%PROD_HOME%/README 16382 plats=0=>[[46]] langs=0=>[[en]]]]
]]
DllGroup = false

Calling action unixActions2.2.0.6.0 createLink
source = /opt/oracle/jre/1.1.8/bin/.java_wrapper
destination = /opt/oracle/jre/1.1.8/bin/jre
overwriteExistingLink = true
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #98867 is a reply to message #98866] Tue, 27 May 2003 11:16 Go to previous messageGo to next message
Thomas
Messages: 67
Registered: September 1999
Member
Try the following before running the installer:

(in bash:) export LD_ASSUME_KERNEL=2.4.1
(in tcsh:) setenv LD_ASSUME_KERNEL 2.4.1

Could you post back if you actually get it installed all the way? I've had the same problem you have and the environment variable fixed it, but later in the installation process, I get an error that won't let me finish the installation process. I get:

Error in invoking target install of makefile
../OraHome1/network/lib/ins_oemagent.mk

If you get past this/find a solution for this error, it would be much appreciated if you posted back.
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #98868 is a reply to message #98867] Tue, 27 May 2003 14:07 Go to previous messageGo to next message
marco
Messages: 46
Registered: March 2001
Member
The LD_ASSUME_KERNEL solution worked for me too.

After that I ran into the same problem as you. At 69% it crashed on the ins_oemagent.mk.

I haven't found the solution yet. I found some answers about similar problems, I tried them but it didn't work. I have posted the problem on the metalink forum, but still no answer.

Just for extra information:
After that I tried in installation on 9.2.0.1.0 on Red Hat 8.0. Both problems didn't occur and the installation succeeded.
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #98869 is a reply to message #98866] Wed, 28 May 2003 02:07 Go to previous messageGo to next message
marco
Messages: 46
Registered: March 2001
Member
Maybe this is the solution. I haven't tried it yet. Although I already tried something similar and that didn't work. If it works for someone, let me know. I will try it later on.

Try the following:
When you see the error "Error during linking <file_name>.mk",
(a) Open a new terminal window
Login as oracle user:
cd $ORACLE_HOME/bin
cp genclntsh genclntsh.bak
(b) Edit the file genclntsh with any editor like vi.
(c) Look for the following line under the section "Create library"
${LD} ${LD_RUNTIME} ${LD_OPT} ${LD_OUT} ${LD_SELF_CONTAINED}
(d) Remove ${LD_SELF_CONTAINED} and save the file.
(e) Run the genclntsh script,
./genclntsh
(f) Go back to the Installer and click "Retry".
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #98870 is a reply to message #98868] Wed, 28 May 2003 07:43 Go to previous messageGo to next message
Thomas
Messages: 67
Registered: September 1999
Member
Yeah, I also posted the problem on metalink a few weeks ago. They said that Red Hat 9 isn't supported and that was it. They didn't give me any more help.
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #98871 is a reply to message #98869] Wed, 28 May 2003 11:05 Go to previous messageGo to next message
Thomas
Messages: 67
Registered: September 1999
Member
Nope, this method didn't work me. The script had this error:

genclntsh: Could not locate /rdbms/admin/shrept.lst /precomp/admin/shrept.lst /plsql/admin/shrept.lst /ldap/admin/shrept.lst /network/admin/shrept.lst
genclntsh: exiting ...

If you go into $ORACLE_HOME/install and open up make.log, at the end of the file, you can see that there are a lot of compile errors along the lines of:
undefined reference to ctype

I don't know if that has anything to do with it.
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #99028 is a reply to message #98867] Tue, 23 March 2004 14:33 Go to previous messageGo to next message
Steve
Messages: 190
Registered: September 1999
Senior Member
Hello,

I ran into the same issue installing Oracle 9.2.0.1.0 custom client. Once I saw your LD_ASSUME_KERNEL setting I realized that I had used it before. On my RH9 I use LD_ASSUME_KERNEL=2.2.5 this got me through the install piece just fine. An error creeped up in the second peice stage of the install, something about linking OracleClient. I hit continue, then ignore. The intallation was successful and my Oracle client is up and running.
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #99047 is a reply to message #98868] Sat, 17 April 2004 18:30 Go to previous messageGo to next message
aamir
Messages: 5
Registered: August 2002
Junior Member
Dont panic just stop at the dialodge , open a new terminal and go to install open make.log, copy the last line from gcc ...................... -lad....

then add manuall -ldl then run it, close it go to dialodge again and press ignore , ur installation will go fine. INSA.

AAMIR
Re: install oracle 9.2.0.1.0 on RedHat 9.0 [message #99212 is a reply to message #98871] Mon, 01 November 2004 06:59 Go to previous message
shruti
Messages: 9
Registered: December 2002
Junior Member
Did you get a response to this? this is exactly what I am getting.
Previous Topic: ORA-27125 on Fedora Core 2
Next Topic: running Installer
Goto Forum:
  


Current Time: Sun Nov 27 02:50:58 CST 2022