Home » Infrastructure » Linux » help: Oracle 9i on RH 7.3
help: Oracle 9i on RH 7.3 [message #98880] Thu, 19 June 2003 09:28 Go to next message
CRodgers
Messages: 1
Registered: June 2003
Junior Member
Newbie Linux needs help with Oracle installation

Wanting to load O 9.2.0.1.0 onto RH 7.3
OUI installs all products with minimal error [[it seemed]].

ora> SQLPLUS fails to start Oracle:
ERROR 'error while loading shared libraries: libclntsh.so: cannot open shared object file: no such file'

From various web posting, I later added GLIBC 2.2.5

Found 5 libc* files on install disks, and tried to install the libraries manually:
ora> /libclntsh.so.9.0 [[a 10.2M file]]
ERROR: 'Segmentation fault'

From /oraInstall/logs:
'home/ora/OraHome1/bin/otrccref: error while loading shard libraries: libclntsh.so: cannot open shared object file: no such file'
NOTE: this is the only error in 'oraInstall2003-06-12_03-09-49PM.err' file

Attempted to execute
ora> ./home/ora/OraHome1/bin/ortccref
ERROR 'error while loading shared libraries....same error from sqlplus

Any help would be appreciated.

Clayton
Re: help: Oracle 9i on RH 7.3 [message #98883 is a reply to message #98880] Fri, 20 June 2003 06:16 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10706
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
this is a how-to-doc written by a colleague of mine.
follow this you can do it.!
[size=7]How to Install Oracle 9iR2 on Redhat 7.3/8.0/9.0[/size]

[b]By

Bob Brady, Ph.D.[/b]
 

Preinstall Checklist

·	Recommended minimum of 384 Mb RAM, 1 Gb swap, 100 Mb free /tmp, and 3 Gb free in /.

·	Install latest java sdk.

·	Symbolically link java sdk root directory to /usr/local/java:				 “ln –s /usr/java/j2sdk1.4.1 /usr/local/java”, Oracle looks for java in this location.

·	Set the kernel parameter shmmax to about ½ the size of physical memory and preferably, 1 Gb: 								    “echo ‘expr 1024*1024*1024’ > /proc/sys/kernel/shmmax.  		     This will be needed in order to create the starter database.  This only temporarily sets the shmmax until the next reboot.  This temporary setting is only needed to install the starter database.

Download and Unpack Oracle

	Oracle can be downloaded free from their web site.  9iR2 comes as three gzipped cpio files.  There have been cases where the download links have been labeled as gzipped files, but Oracle forgot to actually do the zipping.  Unpack as follows:

# cpio –idmv < lnx_92_Disk1.cpio
# cpio –idmv < lnx_92_Disk2.cpio
# cpio –idmv < lnx_92_Disk3.cpio

This can take several minutes.

Create DB Groups, Oracle User, File Structure

# groupadd oinstall
# groupadd oper
# groupadd dba
# useradd –g oinstall –G dba,oper oracle
# passwd oracle
# mkdir /large_dir/u01 (where /large_dir has 3 Gb or more free).
# chown –R oracle.oinstall /home/oracle
# chown –R oracle.oinstall /large_dir/u01
# mkdir /var/opt/oracle
# chown oracle.dba /var/opt/oracle

Add the following lines to the oracle .bash_profile or analogous lines to the appropriate .profile:

# Oracle Environment Variables (PATH & CLASSPATH) included

# NOTE: IN THIS CASE A “/LARGE_DIR/U01” VALUE OF
# “/USR/ORACLE/U01” WAS USED AS ORACLE ROOT DIR

export ORACLE_HOME=/usr/oracle/u01/app/oracle/product/9.2.0
export ORACLE_BASE=/usr/oracle/u01/app/oracle
export ORACLE_TERM=xterm
# ORACLE_SID can be any unused ORACLE_SID name, This
# example uses “jura1”
export ORACLE_SID=jura1
export PATH=$PATH:$ORACLE_HOME/bin:/usr/local/java/bin
export LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib:/usr/local/lib
CLASSPATH=$ORACLE_HOME/JRE:$ORACLE_HOME/jlib
CLASSPATH=$CLASSPATH:$ORACLE_HOME/rdbms/jlib
CLASSPATH=$CLASSPATH:$ORACLE_HOME/network/jlib
CLASSPATH=$CLASSPATH:$ORACLE_HOME/jdbc/lib/classes12.jar:.
export CLASSPATH

For RedHat 9.0 add the following:

export JAVA_HOME=/usr/local/java_1.4.1_or_above
export LD_ASSUME_KERNEL=2.4.1

Run the Oracle Installer

	Open an oracle shell.  Also keep a root shell open, as you’ll need it to run two scripts during the install.  As user oracle, run the executable runInstaller from the unpacked Disk1 directory.   A java GUI will pop-up in after several seconds.

	IF YOU EVER NEED TO ABORT THE INSTALL PROCESS, DELETE THE ORAINST.LOC FILE IN /ETC BEFORE YOU ATTEMPT A REINSTALL.

	The Oracle installer will read the Oracle environment variables from user oracle’s profile.  Picking the default install values displayed will be fine for a starter database install.  There are a few values, however, that you’ll have to type in at install runtime.

	The first install value you’ll have to type in is the Unix group which has permission to update Oracle.  This would be the group “oinstall”.

	Next, select to install the enterprise edition of Oracle.

	Select the typical starter database install.
	Pick a global database name.  This would be the ORACLE_SID concatenated with the fully qualified machine name.  For example, “jura1xxxxxx ”, where the ORACLE_SID is “jura1” and the install machine is “juraxxxxxxxx”.

	About 90% through the link part of the install you will get an error complaining about ins_ctx.mk.   DO NOT QUIT THE INSTALL.  YOU WILL NEED TO GO TO THE ROOT SHELL AND EDIT A FILE, THEN CLICK THE RETRY BUTTON.  The error results because a switch has not been set in $ORACLE_HOME/ctx/lib/env_ctx.mk.  Open env_ctx.mk and add $(LDLIBFLAG)dl into the line “INSO_LINK=-L$(CTXLIB) $(LDLIBFLAG)m X” right at the “X” position.  The “X” position is probably not critical.  Now click the “retry” button on the installer.  Everything should compile fine now.

	For RedHat 9.0: You will get make errors for oemadmin and a few others.  Simply click the ignore button.  You will have to be sure LD_ASSUME_KERNEL is set to 2.4.1 to use java GUI tools such as netca, etc. when using Oracle.

	The creation of the starter database will seem to hang, don’t quit the install!  It takes several minutes for GUI to fully materialize and complete the process.  Be sure to change the passwords for system and sys when prompted by the installer.

	Everything should have gone fine by now.  As user oracle, go to $ORACLE_HOME/Apache/Apache/bin and run “apachecltl stop” to kill the annoying apache service that Oracle forces you to install.

Oracle should now running.  Type “$ sqlplus scott/tiger” to login as the default Oracle user.

Starting Oracle

	Login as user oracle.  Type:

$ sqlplus /nolog

You’ll get a SQL prompt: “SQL>”.  Type:

SQL> connect /as sysdba

Then type:

SQL> startup

Now exit “SQL> exit”.

Stopping Oracle

Login as user oracle.  Type:

$ sqlplus /nolog

You’ll get a SQL prompt: “SQL>”.  Type:

SQL> connect /as sysdba

Then type:

SQL> shutdown

Now exit “SQL> exit”.

aide d'installation oracle(9r2) sous red hat 8.0 [message #98970 is a reply to message #98880] Wed, 21 January 2004 01:39 Go to previous messageGo to next message
jakaria
Messages: 1
Registered: January 2004
Junior Member
Apres les différents paramétrages, j'ai monté le cd d'oracle et ensuite taper la commande
/mnt/cdrom/install/linux/runInstaller et ensuite l'erreur suivante et survenue:/temp/OraInstall2004-01-21-10-56-22AM/jre/bin/i386/native-threads/java:error while loading shared librairies:libstdc++-libc6.1-1.so.2: cannot open object file.
aidez moi SVP à résoudre ce probléme
Re: help: Oracle 9i on RH 7.3 [message #99203 is a reply to message #98883] Thu, 21 October 2004 07:27 Go to previous messageGo to next message
Sumit
Messages: 21
Registered: December 2000
Junior Member
Hello,
this is a very nice article and you have provided all the information in simple languagar alogwith the commands. thanks you a lot.

I need one more thing from your side. Do you have an idea of installing Oracle 11i application on Red Hat 3 (entrprise edition)? or Have you know any such article which resembles to your and made task easy for novoice?
Re: aide d'installation oracle(9r2) sous red hat 9.0 [message #99207 is a reply to message #98970] Mon, 25 October 2004 05:49 Go to previous message
Bell
Messages: 3
Registered: June 2004
Junior Member
Help us to install Oracle 9iR2 under Linux Redhat 9.0
Previous Topic: Installing forms 6i on linux
Next Topic: ORA-27125 on Fedora Core 2
Goto Forum:
  


Current Time: Sun Dec 04 04:59:18 CST 2022