Home » Server Options » RAC & Failsafe » 10G RAC installation, vipca hangs!!
10G RAC installation, vipca hangs!! [message #143612] Fri, 21 October 2005 04:14 Go to next message
ankurgodambe
Messages: 45
Registered: March 2005
Member
Hi,

I have been trying to install 10G R2 RAC in Linux AS release 4.
While installing clusterware software I get the error "The given interface(s), "eth0" is not public. Public interfaces should be used to configure virtual IPs.". So as per the installation docs I refered and metalink, I started vipca manually so that vip is configured.
But vipca hangs at 45% saying "Starting VIP application resource on (2) nodes" . This goes on for hours without error. I also tried to configure it through "srvctl add nodeapps -n " but even this goes on and hangs without any error. Can someone tell me where is the problem?

Help!!

Thanks.
Re: 10G RAC installation, vipca hangs!! [message #144060 is a reply to message #143612] Mon, 24 October 2005 18:35 Go to previous messageGo to next message
Vamshee
Messages: 32
Registered: February 2005
Member
Could you please paste your /etc/hosts file .

Thanks
Vamshee
Re: 10G RAC installation, vipca hangs!! [message #144062 is a reply to message #144060] Mon, 24 October 2005 19:04 Go to previous messageGo to next message
Vamshee
Messages: 32
Registered: February 2005
Member
Also, please place the results after issuing the [ifconfig -a} command from both the nodes.
Thanks
Vamshee

[Updated on: Mon, 24 October 2005 19:05]

Report message to a moderator

Re: 10G RAC installation, vipca hangs!! [message #144348 is a reply to message #143612] Wed, 26 October 2005 03:41 Go to previous messageGo to next message
ankurgodambe
Messages: 45
Registered: March 2005
Member
/etc/hosts from node-1
----------------------
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
172.16.196.61 curly.ketera.com curly
172.16.196.60 moe.ketera.com moe
192.168.0.1 int-moe
192.168.0.2 int-curly
172.16.196.64 vip-moe
172.16.196.65 vip-curly

/etc/hosts from node-2
----------------------
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
172.16.196.61 curly.ketera.com curly
172.16.196.60 moe.ketera.com moe
192.168.0.1 int-moe
192.168.0.2 int-curly
172.16.196.64 vip-moe
172.16.196.65 vip-curly

ifconfig -a on node-1
---------------------
eth0 Link encap:Ethernet HWaddr 00:0D:56:BA:90:FA
inet addr:172.16.196.60 Bcast:172.16.196.255 Mask:255.255.255.0
inet6 addr: fe80::20d:56ff:feba:90fa/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:478786 errors:0 dropped:0 overruns:0 frame:0
TX packets:410687 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:140657494 (134.1 MiB) TX bytes:36572722 (34.8 MiB)
Interrupt:217

eth1 Link encap:Ethernet HWaddr 00:0D:56:BA:90:FB
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:56ff:feba:90fb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:654 (654.0 b)
Interrupt:225

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:195 errors:0 dropped:0 overruns:0 frame:0
TX packets:195 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:24506 (23.9 KiB) TX bytes:24506 (23.9 KiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

ifconfig -a on node-2
---------------------
eth0 Link encap:Ethernet HWaddr 00:0F:1F:6C:F4:E3
inet addr:172.16.196.61 Bcast:172.16.196.255 Mask:255.255.255.0
inet6 addr: fe80::20f:1fff:fe6c:f4e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:143124 errors:0 dropped:0 overruns:0 frame:0
TX packets:31123 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:11907630 (11.3 MiB) TX bytes:2895133 (2.7 MiB)
Interrupt:217

eth1 Link encap:Ethernet HWaddr 00:0F:1F:6C:F4:E5
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20f:1fff:fe6c:f4e5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5 errors:0 dropped:0 overruns:0 frame:0
TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:332 (332.0 b) TX bytes:1386 (1.3 KiB)
Interrupt:225

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:393764 errors:0 dropped:0 overruns:0 frame:0
TX packets:393764 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11436356 (10.9 MiB) TX bytes:11436356 (10.9 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Re: 10G RAC installation, vipca hangs!! [message #144491 is a reply to message #143612] Wed, 26 October 2005 16:43 Go to previous messageGo to next message
Vamshee
Messages: 32
Registered: February 2005
Member
Thanks for posting the information.

I just wanted to make sure if you are running the vipca( as a root user from primary node) in GUI mode, if not please run it in GUI(only) by setting your DISPLAY variable accordingly to your X server.

Also, please make sure under "Network Interfaces" screen to Select the interface for the public network only (eth0 in this example)

Iam looking for some more alternatives, shall let you know accordingly.

Thanks
Vamshee

Re: 10G RAC installation, vipca hangs!! [message #144574 is a reply to message #143612] Thu, 27 October 2005 04:36 Go to previous message
ankurgodambe
Messages: 45
Registered: March 2005
Member
Hi,

Yes I am running it as root, selecting eth0 during the network interfaces screen of the setup

Thanks
Previous Topic: Connect when listener stop
Next Topic: thanks for the information
Goto Forum:
  


Current Time: Wed Dec 08 04:37:29 CST 2021